Easy FancyBoxを1.6.3に更新後に管理画面が表示されなくなる現象の修正方法

Pocket

WordPressで利用している「Easy FancyBox」というプラグインをバージョン1.6.3に更新したところ、WordPressの管理画面が表示されなくなりました。ウェブサーバのログを確認したところ、以下のようなエラーが出ていました。

調べたところ、PHP5.4以降でのみ対応している構文が使われているためだということがわかりました。
修正するには、WordPressが動いているシステムのPHPを5.4以降に更新するか、プラグインのディレクトリの inc/class-easyfancybox-admin.php の21行目の []array() に変更します。

コードで見ると、修正前は以下のようになっています。

これを以下のように修正します。

これで、管理画面が表示されるようになります。